2015 sedan base radio (IO3) to CUE w/o Nav (IO5) upgrade

I'm new here and was wondering if I could get some help. I have decided to upgrade the radio (IO3) in my Base 2015 ATS Sedan (w/o heated seats) to CUE (w/o heated seats or Nav) IO5. I couldn't deal without being able to access the music on my phone (Android).

So far here's the steps I've taken:

I purchased a salvaged CUE radio from a 2015 ATS Coupe (23286469).
Manufacturer: GM
Part Number: 23286469
PARTS: Order by description.

According to parts catalog, this part is compatible with:
2015 Cadillac ATS Base 2.0L L4 - Gas

Prior to removing the base radio I compared the connectors between CUE and base radio/control panel and they appeared to be compatible.

Today I removed the base radio and hooked up the CUE module. Wiring harnesses appear compatible as I had no issues with the 2 connectors. I am aware that the CUE module has a different VIN stored in memory and has to be cleared via a GM MDI with Service Programming System. I haven't quite committed to buying that hardware & software yet as a trip to the dealer may still be cheaper (although no dealer around here has returned my inquiries).

Here is my problem and where I can use your input, once the CUE module was hooked up:

The CUE screen remained black the entire time. I expected to see some sort of indication that the radio was locked via a screen message but I saw nothing, it stayed black. The lid compartment opened and closed as expected and HVAC controls still controlled the A/C and fan although I had no visual feedback of any of the settings. The radio continued to work and was accessible via the steering wheel controls (XM and radio presets were still present and volume controls worked). The home key on the CUE caused the radio to mute (or switch to a particular radio station). The power button didn't appear to do anything.

I tried doing the CUE hard reset thing by leaving the compartment lid opened and power cycling the car with the door opened but that didn't help as the screen remained black. I am not sure if this is expected behavior for a theft locked CUE module or I bought a lemon off of eBay (without a working display).

Has anyone done this swap before? Are the connector pinouts different between IO3 and IO5, maybe the screen portion of the module isn't getting any power? Ive also read that some people have had their CUE screens go black due to software bugs and/or HMI module problems so that gives me hope that the black screen is due to the learned VIN/theft lock. Any help would be much appreciated. I'll post updates as I make progress on this project.